Synced 02 Nov 2026 13:39 UTC Account

Is ActiveMQ 5.0.0 patched?

Apache · cycle 5.0 · end of life
5.0.00/100Critical · exploited

Current stable (6.4.0): 100/100

Minimum safe version5.19.11

5.0.0 has 27 open critical-or-high vulnerabilities. Run 5.19.11 or later to clear them. See what 5.19.11 fixes →

Upgrade impact: Minor upgrade. Minor releases are usually backwards-compatible, but can add or change behaviour — test in staging before production.

1 of the vulnerability affecting 5.0.0 is linked to ransomware campaigns (CISA KEV) — prioritise patching.
Health score0/100
Open issues65
Exploited now3
Cycle 5.0 EOL2008-05-01
Latest release6.4.0

Summary iPlain-English security status for ActiveMQ 5.0.0, built from its CVEs, active-exploitation data, end-of-life date and latest release.

ActiveMQ 5.0.0 is part of the 5.0 release line. 3 actively-exploited vulnerabilities affect it (CISA KEV). 1 is linked to ransomware campaigns (CISA KEV). The minimum safe version is 5.19.11 — upgrade to it or later to clear the open critical/high issues. The 5.0 line reached end-of-life on 2008-05-01, so it no longer receives security patches. The latest supported ActiveMQ release is 6.4.0.

Frequently asked

Is ActiveMQ 5.0.0 patched?

No — 3 actively-exploited vulnerabilities affect ActiveMQ 5.0.0. Upgrade to at least 5.19.11.

What version should I upgrade ActiveMQ 5.0.0 to?

Upgrade ActiveMQ 5.0.0 to at least 5.19.11 to clear its 27 open critical-or-high vulnerabilities.

When does ActiveMQ 5.0 reach end-of-life?

ActiveMQ 5.0 reached end-of-life on 2008-05-01 and no longer receives security patches.

What is the latest version of ActiveMQ?

The latest supported ActiveMQ release is 6.4.0.

Is ActiveMQ 5.0.0 still receiving security updates?

No — ActiveMQ 5.0.0 is on the 5.0 line, which reached end-of-life on 2008-05-01 and no longer receives security updates. Upgrade to 6.4.0 or later to stay supported.

Informational only, from public data (NVD · CISA KEV · EPSS · endoflife.date), and can lag or miss vendor-specific fixes. Always confirm against Apache's official advisory before you patch or upgrade.