CVE-2026-9106
Summary
A UI misrepresentation vulnerability was identified in GitHub Enterprise Server that allowed an OAuth application to gain unintended access to an organization's runner management. An attacker could exploit this by creating an OAuth application requesting the manage_runners:org scope and directing a victim user to authorize it, as the scope was not displayed on the authorization consent screen. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.22 and was fixed in versions 3.21.2, 3.20.4, 3.19.8, 3.18.11, 3.17.17, 3.16.20. This vulnerability was reported via the GitHub Bug Bounty program.
Impact & exploitability
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L
Affected products we track (1)
Recommendation
Apply the vendor fix in your normal patch cycle. Open any affected product above for its exact safe version.
Additional information
- NVD record
- https://docs.github.com/en/enterprise-server@3.16/admin/release-notes#3.16.20
- https://docs.github.com/en/enterprise-server@3.17/admin/release-notes#3.17.17
- https://docs.github.com/en/enterprise-server@3.18/admin/release-notes#3.18.11
- https://docs.github.com/en/enterprise-server@3.19/admin/release-notes#3.19.8
- https://docs.github.com/en/enterprise-server@3.20/admin/release-notes#3.20.4
- https://docs.github.com/en/enterprise-server@3.21/admin/release-notes#3.21.2