CVE-2026-114718
Summary
Roundcube Webmail before 1.6.20 and 1.7.x before 1.7.5 is affected by a cross-site scripting vulnerability in the password plugin. Error text returned by a password driver was concatenated into the message presented to the user without HTML escaping, so a backend able to influence that text, such as the DirectAdmin API, could inject script into the Roundcube interface. Upstream fixed this in the commit “Fix XSS issue in handling of password driver error responses”, which escapes the driver message before display.
Impact & exploitability
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
Affected products we track (1)
Recommendation
Apply the vendor fix in your normal patch cycle. Open any affected product above for its exact safe version.
Official patch: https://github.com/roundcube/roundcubemail/commit/16bbca70b668e85332f23333946a764865bead94 ↗
Additional information
- NVD record
- https://github.com/roundcube/roundcubemail/commit/16bbca70b668e85332f23333946a764865bead94Patch
- https://github.com/roundcube/roundcubemail/commit/94298856ee67ff7817cc4def2adb634be91e28c7Patch
- https://roundcube.net/news/2026/10/19/security-updates-1.6.20-and-1.7.5Advisory
- https://bugs.debian.org/1151279Advisory
- https://github.com/roundcube/roundcubemail/releases/tag/1.6.20
- https://github.com/roundcube/roundcubemail/releases/tag/1.7.5