Is APISIX 2.10.5 patched?
Current stable (3.19.0): 100/100
2.10.5 has 7 open critical-or-high vulnerabilities. Run 3.18.0 or later to clear them. See what 3.18.0 fixes →
Upgrade impact: Major upgrade. Crossing a major version usually means breaking changes. Review the vendor’s upgrade / migration guide and test before you roll it out.
Summary iPlain-English security status for APISIX 2.10.5, built from its CVEs, active-exploitation data, end-of-life date and latest release.
APISIX 2.10.5 is part of the 2.10 release line. 1 actively-exploited vulnerability affects it (CISA KEV). The minimum safe version is 3.18.0 — upgrade to it or later to clear the open critical/high issues. The 2.10 line reached end-of-life on 2022-04-01, so it no longer receives security patches. The latest supported APISIX release is 3.19.0.
Known issues affecting 2.10.5
Exploited first, then by exploitation probability.
CVE-2023-44487 HIGH exploited EPSS 100% → fixed in 3.6.1 CVE-2022-29266 HIGH EPSS 8% → fixed in 2.13.1 CVE-2022-25757 CRITICAL EPSS 2% → fixed in 2.13.0 CVE-2026-39999 CRITICAL EPSS 1% → fixed in 3.17.0 CVE-2025-46647 MEDIUM EPSS 0% → fixed in 3.12.0 CVE-2025-62232 HIGH EPSS 0% → fixed in 3.14.0 CVE-2026-44046 MEDIUM EPSS 0% → fixed in 3.17.0 CVE-2026-44087 CRITICAL EPSS 0% → fixed in 3.17.0 CVE-2026-31923 HIGH EPSS 0% → fixed in 3.16.0Other APISIX versions
Check another release line of APISIX.
Frequently asked
Is APISIX 2.10.5 patched?
No — 1 actively-exploited vulnerability affects APISIX 2.10.5. Upgrade to at least 3.18.0.
What version should I upgrade APISIX 2.10.5 to?
Upgrade APISIX 2.10.5 to at least 3.18.0 to clear its 7 open critical-or-high vulnerabilities.
When does APISIX 2.10 reach end-of-life?
APISIX 2.10 reached end-of-life on 2022-04-01 and no longer receives security patches.
What is the latest version of APISIX?
The latest supported APISIX release is 3.19.0.
Is APISIX 2.10.5 still receiving security updates?
No — APISIX 2.10.5 is on the 2.10 line, which reached end-of-life on 2022-04-01 and no longer receives security updates. Upgrade to 3.19.0 or later to stay supported.
Informational only, from public data (NVD · CISA KEV · EPSS · endoflife.date), and can lag or miss vendor-specific fixes. Always confirm against Apache's official advisory before you patch or upgrade.